1

Closed

Assertion Failed: Satellite DLL not found. (resource)

description

Hi at VsTortoise team.

just installed TortoiseSVN-1.8.2.24708-x64-svn-1.8.3.msi on a Win 7 Ultimate SP1 Workstation (and upgraded working copies). Run vstortoise32beta_svn18.exe successfully for Vs 2008 (only). On starting VS IDE get a permanent "Assertion Failed" message and VsTortoise menu does not appear as well as VsTortoise context menues are missing.
Previous Version (vstortoise30beta_svn17.exe) worked well with TortoiseSVN-1.7.13.24257-x64-svn-1.7.10.msi in the same environment.

Do I have to use an older version of TortoiseSvn-1.8 (noting that TortoiseSvn-1.8.3 ... is just available)?

Btw: Thanks for the tool (in hope that there is some way to use the new one)

Jep0710

file attachments

Closed Feb 7, 2014 at 6:57 AM by pschraut
Fixed in beta 33, revision 74492.

comments

pschraut wrote Oct 28, 2013 at 4:15 PM

Hi Jep, that issue is really strange. Another user experienced the same problem (https://vstortoise.codeplex.com/workitem/10418) and I'm currently trying to get my head around the problem. One thing that might cause this issue is that I did build the plugin and satellite dll with VS 2010. In the past, I used either 2005 or 2008.

Do you use Visual Studio 2008 english or another language? In the linked issue, I wrote I'll compile the project with 2008 and upload the files, so you can check if this solves the problem.

Jep0710 wrote Oct 28, 2013 at 5:25 PM

Hi,

yes, my VS 2008 is the english version (see below) but on a german OS (was not my choice: I did not set up the machine). Maybe I should have noted that I click on "Ignore" because the other two buttons tend to terminate VS 2008 IDE.

(Btw: Sorry, I didn't search for "v32beta: missing satelliteDLL" but for "satellite Dll" and "Assertion".)

Shall I try to get the source code and compile it on my own to see if it is working?

Regards

Jep0710
Microsoft Visual Studio 2008
Version 9.0.30729.1 SP
Microsoft .NET Framework
Version 3.5 SP1
Installed Edition: Professional
. . .
<<

Jep0710 wrote Oct 28, 2013 at 5:37 PM

Shall I try to get the source code and compile it on my own to see if it is working?<<
Ah, sorry. Misinterpreted the text in the linked issue: The recommendation was to build in VS 2005 on "his" own. You will post link to VS 2008 build.

pschraut wrote Oct 28, 2013 at 6:47 PM

Exactly, I'll build a version using VS 2008 and upload the setup. I don't have access to VS 2005 anymore, 2008 is the oldest VS I have. Installing 2008 right now, so I should be able to upload a test build in one or two hours.

wrote Oct 28, 2013 at 8:07 PM

pschraut wrote Oct 28, 2013 at 8:07 PM

I did rebuild VsTortoise 32 Beta with VS 2008, you can find the setup attached to this ticket. Please let me know if it works for you.

wrote Oct 28, 2013 at 8:08 PM

pschraut wrote Oct 28, 2013 at 8:08 PM

added vstortoise32beta_compiled_with_vs2008_svn17.zip

wrote Oct 28, 2013 at 8:09 PM

pschraut wrote Oct 28, 2013 at 8:09 PM

added vstortoise32beta_compiled_with_vs2008_svn16.zip

Jep0710 wrote Oct 28, 2013 at 8:41 PM

Thanks. I'll test it ... tomorrow (already home now).

Jep0710 wrote Oct 29, 2013 at 10:10 AM

Hello Peter,

works as expected: No assertion, main menu and context menues available and work (diff, commit etc. show up the dialogs expected).

Thanks very much! Regards

Jep0710

pschraut wrote Oct 29, 2013 at 10:14 AM

Hi Jep, I'm glad it works! Thank you very much for letting me know!

BuzaL wrote Oct 30, 2013 at 11:48 AM

Works for me, too! (I tested the svn17 version, on vs2005)

pschraut wrote Oct 30, 2013 at 3:20 PM

Hey BuzaL, thanks for the confirmation! Nice that it also works with 2005 again!

JimMcLaren wrote Nov 1, 2013 at 3:42 PM

Just to let you know, I had the same issue. This fixed it for svn 1.6 with VS 2008.

pschraut wrote Nov 1, 2013 at 6:34 PM

Hi Jim, thanks for the feedback!

wrote Feb 7, 2014 at 6:57 AM